Aufbau des Text- und Indexfensters

In diesem Kapitel wird der Aufbau des Text- und des Indexfensters in der Analyseumgebung (vgl. Öffnen der Analyseumgebung) mit folgenden Punkten erläutert:

Die verschiedenen Funktionalitäten des Index- und Textfensters werden in Pop-up-Menüs angezeigt. Pop-up-Menüs sind für einen bestimmten Bereich der Benutzerfläche definiert. Sie werden erst durch rechten Mausklick in einem bestimmten Bereich der Benutzeroberfläche sichtbar.

Das Textfenster

Auf der rechten Seite in der Analyseumgebung befindet sich das Textfenster. Dieses enthält den zu indizierenden Quellentext, der entweder in der Auswahlliste oder über die Textstellenverweise im Indexfenster angewählt wurde. Es besteht aus zwei Teilbereichen.

Analyse_Ansicht_Textfenster.png

Abb.: Ansicht Textfenster

In der Mitte des Textfensters befindet sich der Anzeigebereich, der den für die Analyse ausgewählten Quellentext enthält. Der Anzeigebereich lässt sich über die rechts angebrachte Scrollbar sowie über die Tastatur nach unten und oben bewegen. Direkt oberhalb des Anzeigebereichs befinden sich Informationen zum geladenen Dokument, die aus der Inventarisierungsmaske generiert wurden (z. B. Dokument-ID, Dokumenttyp, Name des Besitzers des Dokuments, Titel, Datum, Ort etc.). Angezeigt werden ebenfalls Angaben zu der Person, die den ausgewählten Indexeintrag vorgenommen hat.

Dokumente ins Textfenster laden

Der Nutzer kann über die Menüpunkte "Analyse" und "Kategorienschema öffnen" eine kategorien- bzw. stichwortbezogene Auswahl von indizierten Dokumenten im Rahmen der Sach- und Semantikanalyse vornehmen. Durch das Auswählen der entsprechenden Textstellenverweise, die hinter den zugehörigen Indexeinträgen im Indexfenster aufgelistet sind, wird das entsprechende Dokument im Textfenster geladen. Beim Auswählen von Textstellenverweisen im Indexfenster wird der zugehörige Quellentext samt indizierten Textpassagen im Textfenster geladen. Die zum angewählten Textstellenverweis zugehörige farblich markierte Textstelle erscheint ganz oben im Textfenster. Zur besseren Übersichtlichkeit sind sowohl der angewählte Textstellenverweis als auch die entsprechende Textpassage im Textfenster aktiv geschaltet.

Von der Analyseumgebung zur Inventarisierungsumgebung ("Switch-Funktion")

Befindet sich der Benutzer in der Analyseumgebung und hat darin ein Dokument geöffnet, so kann er von hier direkt zur Inventarisierungsumgebung wechseln, um zum Beispiel Korrekturen am Text durchführen zu können. Hierzu klickt der Nutzer mit der rechten Maustaste im Textfenster der Analyseumgebung. Daraufhin erscheint ein Pop-up-Menü, in dem der Menüpunkt "Bearbeiten" angewählt wird. Im Anschluss wird in die Inventarisierungsumgebung gewechselt und dasselbe Dokument hier geöffnet. Nun kann im Texteditor der Text wie gewohnt bearbeitet werden.

Für den Wechsel von der Inventarisierung in die Analyse siehe hier

Analyse_Textfenster_bearbeiten.png

Abb.: Pop-up-Menü im Textfenster - Menüpunkt "Bearbeiten"

Im Texteditor des Dokuments werden indizierte Textstellen hellgrau dargestellt. Hierbei handelt es sich also nicht um Formatierungen (die z. B. auf einem Ausdruck sichtbar sind).

Analyse_indizierte_Textstellen.png

Abb.: Darstellung von indizierten Textstellen im Texteditor

Suchen im Textfenster

Im Textfenster der Analyseumgebung hat der Nutzer die Möglichkeit, nach einzelnen Wörtern oder ganzen Begriffen zu suchen. Es besteht ebenfalls die Möglichkeit, nach Wortfragmenten zu suchen. Hierzu klickt der Benutzer mit der rechten Maustaste in das Textfenster. Daraufhin erscheint ein Pop-up-Menü, in dem der Menüpunkt "Suchen" ausgewählt wird. In der nun erscheinenden Dialog-Box "Suchen" wird im freien Feld der Suchbegriff eingegeben. Bei der Eingabe des Suchbegriffs ist zu beachten, dass ein Unterschied zwischen Groß- und Kleinschreibung gemacht wird.

Unter dem Suchtextfeld kann der Benutzer auswählen, ab welcher Stelle im Text die Suche gestartet werden soll. Er hat mittels einer Radio-Button-Leiste die Möglichkeit, im Text von vorne suchen zu lassen, oder ab der Stelle, an der zuvor in den Text geklickt wurde. Im Anschluss wählt der Benutzer den Button "Suchen" und im Text wird, falls dort vorhanden, der erste gefundene Begriff farblich markiert. Das Suchfenster wird transparent, sobald der Such-Button betätigt wird.Den nächstfolgenden Begriff findet man, indem man entweder weiter die Entertaste betätigt oder den Button "Suchen" erneut anklickt. Sollte kein weiterer Begriff mehr gefunden werden, erscheint eine entsprechende Meldung. Falls der gesuchte Begriff im Text überhaupt nicht vorkommen sollte, erscheint eine Info-Box mit dem entsprechenden Hinweis.

Möchte der Nutzer die Suche beenden, so klickt er auf den Button "Beenden" im unteren Teil des Suchfensters.

Analyse_Suchen.png

Abb.: Pop-up-Menü im Textfenster - Menüpunkt "Suchen"

Analyse_Suche_2.png

Abb.: Dialogbox "Suchen" mit eingegebenem Begriff - Markierung im Text

Kopieren im Textfenster

Möchte der Benutzer einen Begriff oder sogar einen ganzen Abschnitt des Textes kopieren, so markiert er zunächst den Begriff oder Abschnitt und öffnet anschließend das Pop-up-Menü des Textfensters mittels Rechtsklick. Dort hat er die Möglichkeit, den Menüpunkt "Kopieren" oder "Kopieren (nur Text) auszuwählen. Bei ersterer Option wird der Text samt Formatierung kopiert, bei der zweiten Option lediglich der Text ohne Formatierung. Der kopierte Text befindet sich nach Klick auf eine der beiden Optionen in der Zwischenablage und kann z. B. in Textverarbeitungsprogramme eingefügt werden. Hierbei wird allerdings nur der reine Text ohne Formatierungen oder Markierungen zu Indexeinträgen oder eventuell vorhandenen Notizstellen zu Textstellen kopiert. Sollen diese Informationen mit ausgegeben werden, muss der Text mit Hilfe der Exporttools (vgl. TEI Export) ausgegeben werden.

Analyse_Kopieren.png

Abb.: Pop-up-Menü im Textfenster – Menüpunkt "Kopieren"

Textstellen

Wenn der Benutzer den Text eines Dokuments indiziert hat, d. h. Textstellen zu Indexeinträgen (vgl. Texterschließung in der Freien Analyse), zu Argumenten (vgl. Arbeiten mit einem Index der Argumentationsanalyse) oder zu Lemmata (vgl. Arbeiten mit einem Index der Wortfeldanalyse) hinzugefügt hat, werden diese Textstellen im Textfenster farblich markiert.

grüne Markierung = Textstelle der Freien Analyse; braune Markierung = Textstelle der Argumentationsanalyse; blaue Markierung = Textstelle der Wortfeldanalyse

Analyse_Farbmarkierung.png

Abb.: Darstellung von Textstellen im Textfenster

Fährt der Benutzer mit dem Mauszeiger über die markierte Textpassage, wird in einem Pop-up-Fenster die Zuordnung zum Indexeintrag/Argument/Lemma angezeigt. Sind derselben Textpassage mehrere Indexeinträge/Argumente/Lemmata zugeordnet, so erscheinen sie alle untereinander im Pop-up-Fenster.

Analyse_Textstelle_1.png

Abb.: Grün markierte Textstelle (der Freien Analyse) im Textfenster mit Pop-up-Fenster, das die Zuordnung zum Indexeintrag anzeigt

Textstellen können auch über das Pop-up-Menü der Textstelle im Textfenster angesehen und bearbeitet werden. Hierzu öffnet der Benutzer mit Rechtsklick über der Textstelle im Textfenster das Pop-up-Menü, wählt dort den Menüpunkt "Textstelle" und anschließend die gewünschte Textstelle aus. Nun erscheint ein weiteres Menü, welches dem Benutzer die Möglichkeit zur Anzeige, zur Bearbeitung oder zum Löschen der Textstelle gibt.

Analyse_Textstelle_Anzeigen.png

Abb.: Menüpunkt "Textstelle" im Pop-up-Menü der Textstelle

 

Das Indexfenster

Auf der linken Seite der Analyseumgebung befindet sich das Indexfenster.

Analyse_Indexfenster_1.png

Abb.: Indexfenster: Anzeige des Analyseschemas mit Indexstichworten und den dazu gehörenden Textstellenverweisen in der Freien Analyse

In der Mitte des Indexfensters befindet sich der Anzeigebereich, der die Indexstichworte (schwarz), die Argumente oder die Lemmata (je nach gewählter Analysemethode), die Häufigkeitsangaben hinter den Stichworten in Klammern sowie schließlich die Verweise auf die zugehörigen indizierten Textstellen, die sogenannten Textstellenverweise, enthält. Die Textstellenverweise sind identisch mit der ID des betreffenden Dokuments.

Wenn einem Indexeintrag aus dem gleichen Dokument schon eine andere Textstelle zugeordnet ist, wird die Dokument-ID nicht nochmals angezeigt. Die Textstelle verbirgt sich hinter der gleichen ID.

Die Häufigkeitsangaben hinter den Indexeinträgen geben die Anzahl der Textstellen an, die mit diesem Indexeintrag verbunden sind (ohne Untereinträge). Die Anzahl der angezeigten Textstellenverweise hinter dem Indexeintrag kann von dieser Häufigkeitsangabe abweichend sein, da sich hinter einem Textstellenverweis auch mehrere Textstellen verbergen können.

Falls die Anzeige der Häufigkeitsangaben deaktiviert sein sollte, wenden Sie sich bitte an uns: fud@uni-trier.de

Links der Stichworte befindet sich eine mit +/- Symbolen geordnete Gliederungsleiste, über die im jeweils angewählten, hierarchisch aufgebauten Kategorienschema geblättert werden kann.

Plus-Symbole deuten darauf hin, dass dem angewählten Stichwort weitere Einträge untergeordnet sind. Minus-Symbole deuten darauf hin, dass sich hinter dem angewählten Stichwort keine weitere Hierarchieebene verbirgt. Beim Anklicken der Plus-Symbole wird der Index um jeweils eine Ebene aufgeblättert. Beim Anklicken der Minus-Symbole wird der Index an der betreffenden Stelle zugeklappt. Auch nach dem Wechseln in ein anderes Analyseschema über die Auswahlleiste oberhalb des Anzeigebereichs wird das zuvor bearbeitete Schema nicht geschlossen. Beim erneuten Anwählen wird diejenige Stelle angezeigt, die zuletzt aufgeblättert war.

Die Stichworte sind innerhalb der Schemata auf den ersten beiden Ebenen nach inhaltlichen Gesichtspunkten und ab der dritten Ebene alphabetisch sortiert.

Index aktivieren/deaktivieren

Der Benutzer kann den jeweiligen Index für das geöffnete Dokument entweder aktivieren oder deaktivieren. Ist der Index für das Dokument aktiv geschaltet, so werden die indizierten Textstellen im Textfenster angezeigt.

Analyse_Index_aktiv.png
Abb.: Aktiver Index mit indizierten Textstellen im Textfenster

Wird der Index deaktiviert, werden die Textstellen im Textfenster nicht angezeigt.

Standardmäßig ist im Kästchen vor der Bezeichnung "aktiv" im oberen Bereich des Indexfensters ein Häkchen gesetzt, d. h. der Index ist für das Dokument aktiviert. Möchte der Benutzer diesen Index deaktivieren, entfernt er das Häkchen, indem er darauf klickt. Der Index ist nun deaktiviert.

Suchen im Indexfenster

In einem geöffneten Indexbaum können über die Suchfunktion gezielt Indexeinträge gefunden werden. Hierzu gibt der Nutzer in das leere Suchfeld oberhalb des Indexfensters einen Suchbegriff ein. Es gilt zu beachten, dass zwischen Groß- und Kleinschreibung unterschieden wird. Im Anschluss wird, nachdem der Button "Suche" betätigt wurde, der erste gefundene Eintrag im Indexfenster gelb markiert.

Falls die Suche zu keinem Ergebnis gelangt, wird der Nutzer nicht gesondert darüber informiert, es wird lediglich keine Markierung in den Indexeinträgen angezeigt. Als Treffer gelten auch gefundene Begriffe, die nur einen Teil eines Indexeintrags bilden. So wird z. B. bei der Suche nach "Mauer" auch der Begriff in "Mauerfall" gelb markiert werden. Den nächstfolgenden Begriff findet man, indem man entweder weiter die Entertaste betätigt oder den Button "Suche" ein weiteres Mal anklickt. Sollte kein weiterer Begriff mehr gefunden werden, springt die Suche wieder zum ersten gefundenen Begriff zurück und zeigt diesen wieder gelb markiert an.

Analyse_Indexfenster_Suche.png

Abb.: Suche nach "Leben" - Markierung des Suchbegriffs in "Lebensereignisse"

Zurzeit können nur Einträge in aufgeklappten Indexbäumen gesucht werden. Suchergebnisse, die in nicht auf dem Bildschirm angezeigten Untereinträgen vorhanden sein könnten, werden nicht angezeigt.

(c) 2017   uni_trier.jpg     eSciences Schriftzug     Kompetenzzentrum.gif     FZE-Logo.png Alle Rechte vorbehalten.

gefördert von:      dfg_logo_schriftzug_blau.png    Logo_MWWK_RLP.JPG